After logging out twice the mattermost cloud version changed from cloud-2022-12-01-1 to cloud-2022-11-24-1

We have taken the mattermost cloud enterprise 30-day trial. Because of some testing purposes, I logged out from the account and found that after logging out twice the version is changed to cloud-2022-11-24-1, but previously the version was cloud-2022-12-01-1. I am confirmed about it because I have created another mattermost test workspace and by that one, I got the confirmation after the testing. So, the problem is in this current version (cloud-2022-11-24-1), after logging out while we try to log in back then it is redirecting to the “https://****************.cloud.mattermost.com/select_team” URL instead of the mattermost console/dashboard. Also sometimes the channels are appearing, and sometimes it is disappearing. And while trying to add an incoming webhook no channels are showing (screenshot is attached) but in the “cloud-2022-12-01-1” version, channels were showing. Also, the channels are taking 10/15mins to load. Also while trying to add other members to a channel some illogical errors are generated.
Please help us with this. It is very urgent. How to fix it? Or how to switch back to the mattermost “cloud-2022-12-01-1” version.

Thanks Nisha. I can see that you reached out to our support. We are looking into this.

Hello,

Thanks for the reply.
Again I want to mention the problem that we are facing in the current
enterprise trial.

Last day I got to know that whenever we upgrade mattermost cloud free
version to mattermost cloud enterprise version, the version is changed
to cloud-2022-11-24-1, but previously the version was
cloud-2022-12-01-1. I am confirmed about it because I have created some
other mattermost test workspace and by that one, I got the confirmation
after the testing.
So, the problem is in this current version (cloud-2022-11-24-1) may be,
after logging out while we try to log in back then it is redirecting to
the “Mattermost” URL
instead of the mattermost console/dashboard.
Also sometimes the channels are appearing, and sometimes it is
disappearing.
And while trying to add an incoming webhook no channels are showing
(screenshot is attached) but in the “cloud-2022-12-01-1” version,
channels were showing.
Also, the channels are taking 10/15mins to load. Also while trying to
add other members to a channel some illogical errors are generated.
Another thing is while trying to add a user in a mattermost channel as a
guest, the user is not able to join that channel. The user is getting
the invitation email but whenever they are trying to join from the
invitation email they are getting the interface “Guest users has no
channel assigned etc. etc”, but the user was assigned a channel still it
was showing. Also from the mattermost admin panel, we can find that the
user is added to the team, but not in the channel, and while also
alternatively while trying to add the guest user from the system console
by the mattermost admin in a channel, it’s saying “unable to get the
channel member”.

Above I have again stated all the problems that we are facing to avoid
more time consuming.

Regards,
Nisha

Hi @Nisha thanks for bringing these issues to our attention. For Mattermost cloud support, please file a support request here