I can't access my server after a reboot having enabled TLS with LetsEncrypt

I enabled the TLS settings as set out in the documentation, but I can’t access my server any more. I either get a 502 error or this page…

Any help would be much appreciated.



@george Would you be open to sharing details about your config settings and Mattermost log errors?

1 Like

Hi, @george

Following up on this case, I would assume that you were referring to the Configuring TLS on Mattermost Server. For now, can you please share the following information as suggested by @amy.blais so we can further troubleshoot this problem? :

Troubleshooting Questions

  • How often do you get switched between the 502 Bad Gateway error and the No sign in methods are enabled error?
  • Is it only happening to your account when you try to sign in?
  • Were you trying to sign in using an account that has the System Administrator access?
  • Is the account tied to any AD / LDAP / SSO / Gitlab authentication? What happens when you try to log in using a local user (if any)?

Information Gathering

  • The version of Mattermost Server that you have installed
  • The TLS configuration you applied on the instance
  • A copy of the mattermost.log (please refer to the Mattermost Support Handbook) when you reproduced the problem

Keep us posted.