No admin access on Mac Dev install

I have successfully installed mattermost on Mac (Docker). I can browse to the site but I don’t have permissions to the system console. Any ideas on how to get admin access on a dev docker install?

I found this command to run but ensure where to run it?

./platform -assign_role -team_name=“yourteam” -email="" -role=“system_admin”

run docker exec -ti mattermost-dev /bin/bash to get a bash shell to the docker container then run the -assign_role command

I tried “docker exec -ti mattermost-dev /bin/bash” from the terminal and received the error “Error response from daemon: no such id: mattermost-dev”.

Any ideas?

Sorry just new to developing with go and docker.

Maybe I don’t have mattermost-dev running in docker?

I can browse mattermost in the browser but when I run docker ps it looks like I only have mysql and postgres.

91e91261f6dc postgres:9.4 “/docker-entrypoint.s” 24 hours ago Up 22 hours>5432/tcp mattermost-postgres
299a1953932e mysql:5.7 “/ mysql” 24 hours ago Up 22 hours>3306/tcp mattermost-mysql

oops…sorry I thought you meant you were running inside docker.

If you have a dev machine you can do something like

src/ $ go run mattermost.go -assign_role -team_name="yourteam" -email="" -role="system_admin"

you can also make dist-local and find the platform binary in dist/mattermost/bin/

Thanks Corey worked a treat!