# PUSH-PROXY: how can I turn on logging for the mm-push-proxy?

**URL:** https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115
**Category:** Troubleshooting
**Created:** [March 21, 2016, 4:43pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115 "2016-03-21T16:43:27Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jhr](https://avatars.discourse-cdn.com/v4/letter/j/94ad74/32.png) [@jhr](https://forum.mattermost.com/u/jhr)
#### Post date: [March 21, 2016, 4:43pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/1 "2016-03-21T16:43:27Z")

</div>

Hi  
we have installed a Mattermost server and it is working fine. Push notifications are working also, including the iOS app using the test-push-proxy.  
We did setup our own push-proxy now and re-compiled the iOS app with our own certificates, but we cannot get the push-proxy to work submit the messages. The process is running and answers on port 8066. Is there a way to turn on logging within the push-proxy? The MM log only says that it is has send the notification and does not report any error:

[2016/03/21 17:03:19 CET] [DEBG] Sending push notification to bd2eb7548b930c6b00d9b2b703923b1e2c685831c2b1def7756b59f7704be2d0 wi msg of ‘mmadmin mentioned you in Town Square’

ciao,  
JR

---

<div class="post-metadata">

### Author: ![jhr](https://avatars.discourse-cdn.com/v4/letter/j/94ad74/32.png) [@jhr](https://forum.mattermost.com/u/jhr)
#### Post date: [March 22, 2016, 6:04am UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/2 "2016-03-22T06:04:25Z")

</div>

Add. Info: there are 0 files in /logs, and wie have no idea why.

---

<div class="post-metadata">

### Author: ![jhr](https://avatars.discourse-cdn.com/v4/letter/j/94ad74/32.png) [@jhr](https://forum.mattermost.com/u/jhr)
#### Post date: [March 22, 2016, 1:19pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/3 "2016-03-22T13:19:10Z")

</div>

Hi  
got the log info now.

And this is the problem we are facing:

2016/03/22 14:13:42 ERROR Failed to send apple push sid=tm4p8jbzd38rbnaba94brses7y did=c998fd0d699a757f139b2823a883334ae06996676ce9c33b7c6049237c24a199 err=crypto/tls: failed to parse certificate PEM data

Any suggestions?  
We have installed the latest version of the Push-Proxy on an Ubuntu server  
ciao,  
JR

---

<div class="post-metadata">

### Author: ![coreyhulen](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mattermost.com/coreyhulen/32/25_2.png) [@coreyhulen](https://forum.mattermost.com/u/coreyhulen)
#### Post date: [March 22, 2016, 3:13pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/4 "2016-03-22T15:13:43Z")

</div>

Looks like it failed to parse your cert files. Can you make sure they exist and are in the form of

[https://github.com/mattermost/push-proxy/blob/master/config/config-push-proxy.json#L5](https://github.com/mattermost/push-proxy/blob/master/config/config-push-proxy.json#L5)

```auto
"ApplePushCertPublic": "./config/publickey.cer",
"ApplePushCertPrivate": "./config/privatekey.pem",

```

---

<div class="post-metadata">

### Author: ![jhr](https://avatars.discourse-cdn.com/v4/letter/j/94ad74/32.png) [@jhr](https://forum.mattermost.com/u/jhr)
#### Post date: [March 23, 2016, 12:04pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/5 "2016-03-23T12:04:47Z")

</div>

Hi Corey  
first of all, thanks for your reply.

I have tried what your suggested, but the error is still the same. I did also double check the permissions, files names, path and config-file and it looks all OK.

In the meantime I did verify the certificates, too, and I was able to connect to the Apple Push Server via openssl successfully (no errors):  
**openssl s\_client -connect [gateway.sandbox.push.apple.com:2195](http://gateway.sandbox.push.apple.com:2195) -cert MY.cer -key MY.pem -CApath /etc/ssl/certs**

… Verify return code: 0 (ok)

---

<div class="post-metadata">

### Author: ![jhr](https://avatars.discourse-cdn.com/v4/letter/j/94ad74/32.png) [@jhr](https://forum.mattermost.com/u/jhr)
#### Post date: [March 24, 2016, 5:05pm UTC](https://forum.mattermost.com/t/push-proxy-how-can-i-turn-on-logging-for-the-mm-push-proxy/1115/6 "2016-03-24T17:05:19Z")

</div>

Hi,  
got it all working now. Removing the password from the private key did the trick.  
openssl rsa -in pkey.pem -out newkey.pem  
Which raises the question whether this is still a private key … anyway, problem solved.
