Recommended docker run command fails for mattermost-preview

The latest docker image for mattermost-preview (built 2 days ago) has an error in the entrypoint.
I am getting the following error:

2019-06-23T17:58:03.784559Z 0 [Warning] Insecure configuration for --pid-file: Location ‘/var/run/mysqld’ in the path is accessible to all OS users. Consider choosing a different directory.
2019-06-23T17:58:03.792079Z 0 [Note] Event Scheduler: Loaded 0 events
2019-06-23T17:58:03.792730Z 0 [Note] mysqld: ready for connections.
Version: ‘5.7.26’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 MySQL Community Server (GPL)
Updating CA certificates
Starting platform
./ line 18: /mm/mattermost/bin/mattermost: No such file or directory

As you can see the binary appears to be missing from the image.

I was able to get the platform to run but it took a bit of manual intervention.

I ran the container image with you recommended command line with the exception of redirecting the entrypoint to be bash (–entrypoint /bin/bash) and run interactively (-it)

Once I was in the interactive shell I was able to poke around. The mySQL portion and CA update work fine. The entrypoint script includes trying to run ./bin/mattermost. The only thing it that directory is a binary called platform. I ran that and everything came up. It would appear either a symlink, rename or change to the entrypoint script are missing.