[SOLVED] Failed to send invite email successfully

Hi all,
I trying to configure the mattermost EmailSettings and i’m facing this error :

[EROR] Failed to send invite email successfully err=SendMail: utils.mail.connect_smtp.open.app_error, dial tcp [::1]:25: getsockopt: connection refused

This my config :

“EmailSettings”: {
“EnableSignUpWithEmail”: true,
“EnableSignInWithEmail”: true,
“EnableSignInWithUsername”: true,
“SendEmailNotifications”: true,
“RequireEmailVerification”: false,
“FeedbackName”: “”,
“FeedbackEmail”: "test@example.com",
“FeedbackOrganization”: “”,
“SMTPUsername”: “”,
“SMTPPassword”: “”,
“SMTPServer”: “localhost”,
“SMTPPort”: “25”,
“ConnectionSecurity”: “”,
“InviteSalt”: “ej5zwhb4z4ubgg68m64netppm5tmmrgy”,
“SendPushNotifications”: false,
“PushNotificationServer”: “”,
“PushNotificationContents”: “generic”,
“EnableEmailBatching”: false,
“EmailBatchingBufferSize”: 256,
“EmailBatchingInterval”: 30,
“SkipServerCertificateVerification”: false

The postfix and mattermost servers are installed in the same machine.

Thank you for your help.

Hi @marouane,

Thank you for your feedback,

Could you tell me what is in the Site URL field in System Console > Settings > General > Configuration?

Hi @lindy65,
Thank you for your response, the issue is in relation with the postfix service in centos.
I didn’t check the service if is worked or not , so i turned On the service and i puted localhost as a server , 25 the port number and that’s it.
I followed this link : https://docs.mattermost.com/install/smtp-email-setup.html

Glad you’ve resolved your issue @marouane :slight_smile:

I’ll close this issue off for now then…

Hi @lindy65 ,
I have a question about how can i fix the URL in the mail notification because the user when he receive the mail notif and select the link that suppose to redirect him to the sign up page.
In my case the URL is not correct.
Have you any idea how to fix it from the config or else.

Thank you :slight_smile:

Ok after spending some time searching and sending failed mail , i resolve this by add in my site URL in
System Console -> General -> Configuration : Site URL
That’s it :slight_smile:

Perfect! You beat me to it @marouane :slight_smile:

I was just going to ask you to check that setting…

Pleased your issue is resolved…