# \[Solved\] Problem with migration-assist pgloader when migrating from MySQL to Posgres

**URL:** <https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614>\
**Category:** Troubleshooting\
**Created:** [November 27, 2024, 7:17pm UTC](https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614 "2024-11-27T19:17:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![autoflow](https://avatars.discourse-cdn.com/v4/letter/a/e79b87/32.png) [@autoflow](https://forum.mattermost.com/u/autoflow)\
**Post date:** [November 27, 2024, 7:17pm UTC](https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614/1 "2024-11-27T19:17:20Z")

</div>

**Summary**  
migration-assist pgloader fails when migrating from MySQL to Postgres

**Steps to reproduce**  
migration-assist pgloader --mysql=“\<MYSQL\_DSN\>” --postgres=“\<POSTGRES\_DSN\>” \> migration.load

**Expected behavior**

1. `migration-assist mysql "<MYSQL_DSN>"` succeeded
2. `migration-assist postgres "<POSTGRES_DSN>" --run-migrations --mattermost-version="v10.1.1"` succeeded
3. `migration-assist pgloader --mysql="<MYSQL_DSN>" --postgres="<POSTGRES_DSN>" > migration.load` failed with error

For 3) my command looks in detail like this:  
`./migration-assist pgloader --postgres="postgres://mattermost_db1:PASSWORD@127.0.0.1:5432/mattermost_db1" --mysql="mattermost_db1:PASSWORD@tcp(127.0.0.1:3306)/mattermost_db1" > migration.load`

**Observed behavior**  
For 3) the error message is like this:  
`An Error Occurred: could not generate config: could not parse mysql DSN: no match found`

Can someone help and tell me if my DSNs are somewhere wrong?

---

<div class="post-metadata">

**Author:** ![autoflow](https://avatars.discourse-cdn.com/v4/letter/a/e79b87/32.png) [@autoflow](https://forum.mattermost.com/u/autoflow)\
**Post date:** [November 27, 2024, 8:34pm UTC](https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614/2 "2024-11-27T20:34:28Z")

</div>

Solved, there had been a special char (@) in the password

---

<div class="post-metadata">

**Author:** ![john.combs](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mattermost.com/john.combs/32/7118_2.png) [@john.combs](https://forum.mattermost.com/u/john.combs)\
**Post date:** [December 4, 2024, 1:28am UTC](https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614/3 "2024-12-04T01:28:35Z")

</div>

Thank you autoflow for following up with the solution! Glad to hear all is working now.

---

<div class="post-metadata">

**Author:** ![itGirl27](https://avatars.discourse-cdn.com/v4/letter/i/ba9def/32.png) [@itGirl27](https://forum.mattermost.com/u/itGirl27)\
**Post date:** [December 5, 2024, 5:52pm UTC](https://forum.mattermost.com/t/solved-problem-with-migration-assist-pgloader-when-migrating-from-mysql-to-posgres/21614/4 "2024-12-05T17:52:20Z")

</div>

could you give an example of your mysql dsn that actually worked? I’m experiencing the same issue & can’t figure out why.
