[SOLVED] Upgrading with custom plugin (Server v4.9.2)

Today I attempted to upgrade our Mattermost install from 4.8.1 to 4.9.2. Our install (Linux, not Docker) runs a custom plugin we wrote to modify client CSS. After following the docs to upgrade the site, we discovered that the plugin was no longer installed.

I first attempted to “transfer” the plugin by copying the folder from the install directory backup to the new install directory, but the plugin did not appear in the system console. I next tried stopping and starting the mattermost service (after moving the folder), but the service failed to start. Finally, I removed the folder, successfully started the service, and uploaded the plugin to the system console directly (which worked).

Is there currently an “official” supported method for handling plugins during upgrades?

Hi @jomaxro!

I believe you’ve identified a weakness in our documentation: I’ll follow up to ensure we talk about plugins in the context of upgrading the server.

I would have expected that copying the plugins/ directory from the old install to the new install and restarting the the mattermost service should have worked. By chance do you have the error associated with the server failing to start in that case?

Sadly I do not - at the time I was more concerned with getting our chat server up and running again then saving error logs. I’ll grab the error logs next upgrade (if this recurs).

Worked fine with the last upgrade (copying the plugin folder). I’d still suggest added info about plugins to the upgrade docs, but other than that this can likely be closed.

I opened a PR here to add the missing step to our documentation, will be merged soon: https://github.com/mattermost/docs/pull/2042

1 Like