System center plugin page not found

For feature requests, please see:

For troubleshooting questions, please post in the following format:

I just installed a new mattermost server, but for some reason the plugin page for calls shows a blank page and when i spam F5 i can see temporarly page not found (or something like that). The calls seem to work fine but I can’t even change it from testing to non-testing.

Steps to reproduce
I have no idea how to reproduce that bug the first install worked fine. Removing and adding the plugin again doesn’t change de behavior

Expected behavior

Observed behavior
What did you see happen? Please include relevant error messages and/or screenshots.

Hi @ArnaudT and welcome to the Mattermost forums!

You mean when you go to your system console in the plutins section and click on the calls entry in the left hand side menu, the whole page gets blank or just the part right next to the menu?

Did you already try to open the page in a private browsing tab or to clear all local caches by hitting CTRL-SHIFT-r (or CMD-shift-r if you’re on OSX)?

I have the same problem here. It’s the whole page that gets blank! And I have tried CTRL-SHIFT-R with no results.

My mm version → 7.8.0

Ok, I’ve found a workaround for this. First disable the plugin from the server console with:

sudo bin/mmctl --local plugin disable com.mattermost.calls

and then you are able to configure and re-enable the plugin from the system console! :smiley:

Hi @palevi , welcome to the Mattermost forum and thanks for the workaround!
Would be interesting to see if this also helps @ArnaudT .

Could you see something in the logs when the server starts that might be related to the blank page? Any calls-related errors?

There’s a ticket for this issue now and it’s being investigated: