Updating 7.3 to 7.4 results in error

When updating to v7.4, which seems to work fine, will result in a white screen with 3 loading dots.
In dev tools I can see there is the error “To use Mattermost, please enable JavaScript.” but it is - there is no change at all…

The only error I could find in logs is this line

“level”:“error”,“msg”:“License key from https://mattermost.com required to unlock enterprise features.”,“caller”:“app/license.go:152”,“error”:"resource: License id: "}

However, I didn’t change anything and it’s from the usual download location!?

When rollback to v7.3 it works again like a charm…

Any ideas?

1 Like

Hi PepeLopez,

the error message you’re seeing is OK and should not really be an error message, I think, unless you’re not using the free edition and your license file should be applied but there’s an error while doing so.

Did you try to use CTRL-SHIFT-r in the browser or the desktop app to force a cache-free reload of your client after you upgraded, or maybe try a different device or browser to ensure that there’s not cached items of the previous release when you try to login?

If you did or if this doesn’t help, you could try to enable debug logging in your config.json (set LogSettings.ConsoleLevel and/or LogSettings.FileLevel to DEBUG) and restart the server and see if anything more useful is being logged in the mattermost.log and/or your console output.

It appears on all platform - no matter if browser (even in privacy mode), desktop, mobile, or in the app - after upgrade it won’t work anymore.

Because it’s a production system, I’ll try again this evening with elevated loglevel.

So, I tried it again and upgraded to v7.5.1 - same problem.

With v7.3 mattermost is running fine.
After upgrading to 7.5.1 - it’s running fine as well, but it’s not possible to connect anymore.

Reverting to v7.3 is working fine!

I guess it’s a problem with nginx we’re using, setup is like the docs recommending

Nginx error log says many lines like this

2022/11/18 00:24:06 [error] 2718#2718: *101 connect() failed (111: Connection refused) while connecting to upstream, client: xx.xx.xx.xx , server: mm.mydomain.de, request: "GET /api/v4/plugins/webapp HTTP/2.0", upstream: "", host: "mm.mydomain.de"

Using Mattermost since v5 and upgrading was NEVER an issue.
Did something changed from 7.3 to 7.4 regarding nginx?

Just saying, when upgrading, especially desktop app seems to have problems - even with purged cache and reload it looks like this in desktop app.


Mobile app seems somewhat to work, but not 100% sure so far.

One more info:
With Mattermost v7.3 running, I have desktop app open and I’m connected.
Then I update Mattermost.
Short notice banner with disconnect info (fine so far)
After upgrading & starting Mattermost v7.5.1 there is a banner like “New version available, please reload”
As long as I NOT reload, I still can use Mattermost like sending/receiving messages!
When reloading, the 3 dots of death appearing.

What I found in debug log, maybe someone might help?

{"timestamp":"2022-12-07 14:27:51.785 +01:00","level":"debug","msg":"CSRF Check failed for request - Please migrate your plugin to either send a CSRF Header or Form Field, XMLHttpRequest is deprecated","caller":"app/plugin_requests.go:196","path":"/plugins/focalboard/api/v2/users","ip":"","session_id":"sourqat88jryjkneiwh3xke6ww","user_id":"i91knmiqrb8tirab54ffik1g5o"}

Hi @PepeLopez ,

sorry for the long silence here. Have you managed to fix this issue in the meantime or are you still stuck on 7.3?


Actually I found out, that Cloudflare seems to be problematic.
I’m using Cloudflare pro for the mattermost VM up to v7.3 - which worked flawless.

Starting with v7.4++ it’s necessary to bypass Cloudlfare proxy (it’s possible to do so in DNS settings), just because…
It seems there are changes in v7.4++ regarding webhooks or whatever, and cloudflare is filtering them out. Not sure if additional ports are used or whatever it is, because the changelog doesn’t give any answer to that.
However, when bypassing CF, Mattermost v7.4+ works again.

However, I’d like to suggest to watch this issue - it might interfere with other security related products like firewalls/proxies.

That‘s interesting - I‘m not a Cloudflare user so I don‘t have any experience with that, but according to their documentation, websockets should be handled transparently.

Just to rule out the obvious:
Your server‘s SiteUrl is set to the URL that points to Cloudflare, right?

Are there any connection errors visible on the Cloudflare end?

Screenshot 2023-02-17 at 08.22.11
Hi I have such error app wont lunch

Hi @Mira and welcome to the Mattermost forums!

Please do not hijack other topics, your error is in no way related to what this topic is about, so please create a new topic and include some additional information (version numbers, reproduction instructions, etc.) so we can look at your issue.