How to start WebRTC?

Thanks @noizzzzy.boy, I’ve asked our team + community members to take a look at this.

@noizzzzy.boy A response from an engineer -

Can you try adding this value to the config.json "StunURI": "", without updating the Janus server or any code changes.

The ICE problem can be related to that. If the stun server from google does not work, then maybe you can try another one.

Let me know if this helps?

It was there from the very beginning.
I changed a lot of stun servers with no luck

I have the exact same issue and no matter what i try it wont work.

Any updates on this?

Best regards.

1 Like

Hi @ggisx,

Thanks for reaching out. To give you the best help we can, could you review this web page and send us the relevant logs, config files, etc. which will help us diagnose the issue?

Hi Amy,

I did not set the nat mapping in the janus cfg.

It works perfectly now thanks :slight_smile:

Best regards,



Could you explain nat mapping, I am trying to setup without success I have webrtc on docker and MM on host directly installed, what I am doing wrong, I got creasy now.
4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux
i set nat to public IP on janus.cfg firewal ports for https opened wss also. I somwere full configuration described with proper config of janus in docker. Additionaly haw to use docker webrts and localy MM installed.

Hi @robertl,

Unfortunately WebRTC is known to be unreliable, and I recommend exploring some other plugin options for video calls, e.g.:

Would one of these options work for you?

zoom works, I will se other, but why webrtc is not working for me, do you have any idea ?

Hi @robertl,

WebRTC might fail for many different reasons - one thing you could check is to try adding this value to the config.json "StunURI": "" , without updating the Janus server or any code changes.

Whenever I connect, I get a black screen, and the call drops ~3 seconds after. I never get any voice or video across.
Please let me know if any more info is needed.

configs: (I’ve also tried it with nat_1_1_mapping)

What OS and version is the Mattermost server installed?
debian 8

What is your Mattermost server version?

Are you experiencing the issues with the browser webapp, if so which one?

Can you send a snippet of the Mattermost server logs around the time of the incident? - note that these are the janus logs, not mattermost. Mattermost didn’t have anything interesting in it’s log, but let me know if you need to see it anyway.

Are you running Mattermost in a container and/or using container orchestration?
No, but Janus is in a container

Hi @CaptSpify,

We are slowly removing support for WebRTC because it is known to be unstable (Built-in WebRTC video and audio calls removed in v5.6 in favor of open source plugins), so I recommend exploring other options such as Zoom and Big Blue Button - would one of these sound good?

There’s now a newly created WebRTC plugin for Mattermost, supporting one-on-one voice and video calls, developed by Nikhil Rajan.

There’s no third-party dependancy, and uses a browser-to-browser and serverless approach to initiate calls.

Feedback is highly appreciated!

can you explain how to install in a Docker Deployment I cannot find a generic tutorial for how to add integartions or plugins. There is not anyhting on github either.

Hi @PackElend! You can install plugins from the System Console:

but not before solving the hidden quest to enable plugin upload


it shows only a blank screen as shown in the GitHub issue

Thank you for the heads up, I’ve pinged the plugin author on the GitHub issue.

1 Like

Are you currently using WebRTC?

I introduced it after knowing that a WebRTC plugin was developed on Github.
However, when I installed this plugin, it only added a video icon to the top bar. When I mouse over it, “Start Video Call” appears in a pop-up menu.
The button changes only when I’m interacting with one person by direct message, and the screen switches. The subsequent behavior seems to be the same as the one on Github in PackElend’s post. I can’t make a call by touching the video or microphone icon.
And this is for iPhone only. I can’t do it on a PC. I don’t know Android.

Is there anything else to configure besides this plugin?

CentOS 7.7, nginx 1.16.1, Mattermost Team 5.21.0

This issue might be relevant to what you’re seeing: