Cannot download from desktop in mac

When I try to download an attachment - I get an error "canceled
Screenshot 2023-04-13 at 14.38.19
"
Why is that?

Thnx

Hi @Wojtek ,

this seems to be related to the default download location - at least from what I’ve read in the community forums. Can you please try to change the default download location of the app and see if the problem also persists with the new location? Thanks!

I can confirm the problem. Downloading any files from the Mattermost desktop app to my Mac fails since just recently.

The download fails immediately with a red “cancelled” warning. Clicking on the three dots on the right in the ‘Downloads’ popup and then clicking on “Show in Finder” opens an error message: “Mattermost has no permissions for opening ‘Downloads’”.

I changed the default download location, but without any luck…

The folder permissions are definitely fine and downloading the same file to the same location using the web browser works without a problem.

I could resolve the problem by uninstalling and re-installing the app, but now the same problem just appeared again… which is quite annoying.

I’d appreciate any kind of help!

PS. I’d liked to append screenshots, but uploading them here continuously fails with the message “Sorry, there was an error uploading that file. Please try again.”

Hi @julius.garbe and welcome to the Mattermost forums!

So do I understand you right, you can fix this problem temporarily by reinstalling the app, which makes it work for some time but then it breaks again and does cancel downloads immediately again?

Yes exactly. To be a bit more specific: after reinstalling the app, the problem is fixed for a couple of times at most. It’s definitely no proper solution…

That’s strange, thanks for confirming - will see what I can find out.
When you use the non-appstore version, do these problems go away? You can download the DMG file directly from GitHub.

Hi again,

there’s a known issue with regards to the downloads:
https://mattermost.atlassian.net/browse/MM-52139

The workaround described here in the ticket also worked for one of my workmates - please give it a try (so just pick something else and then switch back to Downloads).

1 Like

Hi everyone…

I have looked and looked but cannot find where to change the download location on Mac for Mattermost. No such option seems to exist in my settings menu.

Hi @agriesser, thanks for taking on this issue.

It indeed seems like the non-appstore version from Github fixes the missing permissions problem of the downloads location. At least I didn’t encounter it anymore since I installed it some few days ago.

Any chance the issue might get fixed in the Appstore version as well soon?

I am also having this problem with version 5.3.1 on Mac. I tried changing the default directory, same problem. Switched back to Downloads and same problem. I have not tried the non-app store install, but it’s a little concerning that they would behave differently.

I confirmed the error on version 5.3.1

Having the same issue. Changing the default location does not help.
The application “Mattermost” does not have permission to open “Documents.”

I gave Mattermost Full Disk Access and that also did not help.

I had the same problem. A colleague (who did as well) found out that it’s fixed if you go to your Mattermost settings, scroll to your download folder and click “edit” (you don’t have to change the directory, just picking the standard one again works fine).