Can't activate plugin

All plugins generate a error and no start

Steps to reproduce

Version de Mattermost : 9.0.0
Version du schéma de la base de données : 113
Base de données : postgres

In docker gitlab (gitlab/gitlab-ce:16.5.2-ce.0)

I check permissions is full for mattermost:mattermost user:group

I enable debug logs, but i’m not found other information

Expected behavior
Describe your issue in detail

Observed behavior

“bundle_path”: “/var/opt/gitlab/mattermost/plugins/com.mattermost.apps”,
“caller”: “app/plugin.go:171”,
“error”: “unable to start plugin: com.mattermost.apps: timeout while waiting for plugin to start”,
“level”: “error”,
“msg”: “Unable to activate plugin”,
“plugin_id”: “com.mattermost.apps”,
“timestamp”: “2023-12-03 15:39:23.066 Z”

“caller”: “plugin/hclog_adapter.go:79”,
“level”: “error”,
“msg”: “plugin process exited”,
“plugin_id”: “com.mattermost.apps”,
“timestamp”: “2023-12-03 15:39:23.066 Z”,
“wrapped_extras”: “path/var/opt/gitlab/mattermost/plugins/com.mattermost.apps/server/dist/plugin-linux-amd64pid22206errorsignal: killed”

Can you help me ? I no longer have any leads to investigate

You need to see the logs inside the container.

docker exec -ti mattermost /bin/bash

1 Like

thank you for your reply.

I didn’t find much more in the gitlab docker console

==> /var/log/gitlab/mattermost/current <==
2023-12-03_21:50:23.46261 {"timestamp":"2023-12-03 21:50:23.462 Z","level":"debug","msg":"plugin started","caller":"plugin/hclog_adapter.go:52","plugin_id":"com.mattermost.demo-plugin","wrapped_extras":"path/var/opt/gitlab/mattermost/plugins/com.mattermost.demo-plugin/server/dist/plugin-linux-amd64pid1451"}
2023-12-03_21:50:23.46288 {"timestamp":"2023-12-03 21:50:23.462 Z","level":"debug","msg":"waiting for RPC address","caller":"plugin/hclog_adapter.go:52","plugin_id":"com.mattermost.demo-plugin","wrapped_extras":"path/var/opt/gitlab/mattermost/plugins/com.mattermost.demo-plugin/server/dist/plugin-linux-amd64"}
==> /var/log/gitlab/mattermost/mattermost.log <==
2023-12-03_21:50:26.46498 {"timestamp":"2023-12-03 21:50:26.464 Z","level":"warn","msg":"plugin failed to exit gracefully","caller":"plugin/hclog_adapter.go:72","plugin_id":"com.mattermost.demo-plugin"}
2023-12-03_21:50:26.46572 {"timestamp":"2023-12-03 21:50:26.465 Z","level":"error","msg":"plugin process exited","caller":"plugin/hclog_adapter.go:79","plugin_id":"com.mattermost.demo-plugin","wrapped_extras":"path/var/opt/gitlab/mattermost/plugins/com.mattermost.demo-plugin/server/dist/plugin-linux-amd64pid1451errorsignal: killed"}
2023-12-03_21:50:26.46584 {"timestamp":"2023-12-03 21:50:26.465 Z","level":"error","msg":"Unable to activate plugin","caller":"app/plugin.go:171","plugin_id":"com.mattermost.demo-plugin","bundle_path":"/var/opt/gitlab/mattermost/plugins/com.mattermost.demo-plugin","error":"unable to start plugin: com.mattermost.demo-plugin: timeout while waiting for plugin to start"}

I test with last gitlab image ([16.6.1-ce.0])… same problem

Version de Mattermost : 9.1.3
Version du schéma de la base de données : 113
Numéro de compilation : 6801074274
Base de données : postgres

Maybe try increasing log verbosity:

1 Like

Hello, thank you for your reply. I have enabled debug logs in both the console and in a file.

I think I’ve found a silent bug, XD.

However, I finally identified the problem, but I don’t understand why it’s occurring.

Experimental chronicles:

To eliminate historical context and dependencies from my GitLab instance, I built a fresh, independent instance of Mattermost.

Even with a fresh install, the same problem occurs. So, it seems the issue lies in the execution context of my instance.

I use SeaweedFS for network storage. Therefore, I moved the plugins and client-plugins directories into local storage.

Success! All plugins can start now. But why? I checked in GitLab, and found that using local storage resolves the issue.

This is good news, but I want to understand why the binary of the plugin starts normally on local storage and not with network object storage when using FUSE mounting.

I find this very strange.