Cant Use S3 Storage

Summary of issue:

RbDev has created an S3 bucket with S3FullAccess policy and a IAM role to give read/write permissions.

They configured S3, saved all changes, and clicked the “Test button” and it returned successful.
When he tried to upload a file, he got an error “there appears to be a problem with your internet connection.”, but going to the s3 repo he could see that the file is there. There are no log errors and the issue happens all the time. is not related.

Hi @RbDev,

The test connection button in the System Console just makes sure the user can connect and check that it can see that the bucket exists, but it doesn’t check that you can actually put an object into the bucket or get one that’s already been uploaded. Can you confirm that the user that you’re using for Mattermost has s3:GetObject permissions?

If it does have have access to that, you could try turning on the FileSettings.AmazonS3Trace setting in Mattermost to see if there’s any more information logged on the server when you try to upload a file.

The only other thing I’d note is that ERR_CONNECTION_REFUSED usually means there’s an issue between your Mattermost server and the web browser, but seeing as the file was uploaded to S3, that doesn’t seem related.

I had to not use S3 because of the permission issues.

I suggest the team to setup a brand new environment and document each step of the way.

Hi @RbDev! Can you help with more details on what permission issues you are seeing?

sure. what do you need?

@RbDev you mentioned that you were experiencing permission issues so I was wondering if you have any additional details on that?

no. I don’t see any errors apart from the ones already posted in this thread.

@RbDev Did the suggestions given by our devs here help Cant Use S3 Storage ?

no sorry. Ive tried this for to long and nothing worked so I went back to standard storage.

Solved the issue for me. Thank you.

Confirming - fresh latest MM installation; required ‘Save’ before testing - definitely a bug in the form.

This is still an issue… first have to hit “Save” before the testing works. This is very counter intuitive and error prone…