Docker install :: "URL is taken or contains a reserved word"

Hi all,

I’ve installed Mattermost on my computer with docker, when I access the service via browser and try to setup the initial team I can’t get past the “Team URL” part.

It always displays “URL is taken or contains a reserved word”.

Anything that i’m missing?

You can disable the reserved words from the System Console -> Team Settings -> Restrict Team Names: set to false

We block things like admin, test, etc.

This is during initial access, at this point I don’d see how to access the System Console.

Or should I be accessing a different URL?

Oops…sorry. You can also just modify the config.json file directly. The System Console is just an easy way to edit the file.

Here’s the setting:

@eric, could we have your help:

  1. Adding this setting to the Configuration Settings guide?

  2. Writing up documentation on creating teams and noting this option?

    Basically the option keeps teams from being named with certain reserved words that could potentially conflict with directory names that may be used in future, e.g. Don’t allow teams to take up the URL namespace “support” in case in future functionality might need to use as a functional path to get to support.

  3. Please open a ticket to link “reserved word” in the UI above to a list of reserved words and an explanation of this feature.

    The functionality would be similar to the “Help” feature under input boxes now on master.

Problem persists, even after config change.

I’ve tried this on two different computers.

Also I’ve tried with several Team names, and (has the server part appears in red) also moved the service to port 80 thus removing the “:” from the URL, all failed.

I had this problem too, but setting Restrict Team Names to false and waiting a little while seemed to do the trick :slight_smile:

Thanks for your response @arvid

@jfig can you confirm that Arvid’s suggestion works for you and solves your issue?