Live URL fails the validation test

Hi, i’ve followed the guide for installing Mattermost via Docker and selected the installation with Nginx. I successfully received certificates through Let’s Encrypt as instructed in the guide. However, when i attempt to test the live URL, i receive the error message: ‘Test unsuccessful: This is not a valid live URL.’ The Mattermost docker container logs provided this information about the failure:

{"timestamp":"2024-02-24 12:35:57.379 Z","level":"debug","msg":"This is not a valid live URL","caller":"web/context.go:113","path":"/api/v4/site_url/test","request_id":"......","ip_addr":"","user_id":"....","method":"POST","err_where":"testSiteURL","http_code":400,"error":"testSiteURL: This is not a valid live URL"}
{"timestamp":"2024-02-24 12:35:57.379 Z","level":"debug","msg":"Received HTTP request","caller":"web/handlers.go:163","method":"POST","url":"/api/v4/site_url/test","request_id":"......","status_code":"400"}

I have also seen another topic discussing this error, but as i see my domain have certificates and should also be a FQDN, but i’ve low knowledge in server configuration, i’m a student and that’s my first experience, so i could definitely be wrong.
The domain i’m using is:
Mattermost Version: 8.1.9
Ultimately, sorry for the dumb question, workspace optimization tells me i have a server update to do (Mattermost Platform release 9.5.1), but i haven’t done it yet because i also need to work with OnlyOffice and the official connector. Could the server update be causing the failure in testing the live URL?

What is the content of SiteUrl in the config file (or if you’re using environment variables since it’s Docker)? Is it or something different? Because I can see that that URL brings up a Mattermost login.

It’s very unlikely that the server version is the issue here. You’ll want to move to 9.5.x some time before 15 MAY 2024 to keep support, but making that change right now is very unlikely to fix. Release Lifecycle — Mattermost documentation

Hi John, thank you for your reply, and yes, i’ve configured the .env file as follow:

#Domain of service
#base .env file, just set proper path to LE cert and key

So the SiteURL field in ENVIRONMENT->Web Server is
I apologize, but is not right that the URL brings up to Mattermost login?
Additionally, i have not modified the rest of the Web Server configuration, from what i’ve read here (Environment configuration settings — Mattermost documentation) it advises to not set the “fordward port 80 to 443” since Nginx handles this task. I’ve understood this correctly or am i missing something?

When I visit I see:

So, from what I can see, it’s working.

For me, resolves to If you have a different DNS view, or an /etc/hosts entry, that’s resolving it to something else, that could explain the error.

Hi, I think i had the same problem. In short my mattermost server is on one vlan and my nginx reverse proxy is on another. My mattermost server worked 100% but that test would fail with the same error. What i found out is my firewall was blocking the vlan with the mattermost server from reaching the vlan with nginx on port 443 and port 80. As a result anyone connecting from the internet would hit nginx, be routed correctly to the mattermost server and everything would work but that test would fail. Once i allowed the vlan with mattermost to reach the vlan with nginx on port 443 and port 80 that resolved that issue.

Hi, thanks for the replies, i appreciate them. I will confirm whether the solution works as soon as we check it.