Mattermost installed but will not load in browser

Build out - Local build with no Internet access. Centos 7 and mysql

User account : MMuser

My SQL Server is running. I verified by running “mysqladmin -u root -p status”, and I was able to get the uptime data.

Reviewing the mattermost.log file there is an entry after attempting to ping the SQL database. " Failed to ping DB", “error 1045”: Access denied for user ‘mmuser’@'hostIPaddress" (Using password:yes)

I was able to check if database exist by login and enter mysql password, and running “Show databases” and the results are below







“DataSource”: “mmuser:mmuser- acctpassword @tcp( HOSTipAddress :3306)/mattermost?charset-utf8mb4,utf8&readTimeout-30s&writeTimeout-30s”

When I run “sudo -u mattermost bin/mattermost” I get the below error message

" Failed to ping DB", “error 1045”: Access denied for user ‘mmuser’@'hostIPaddress" (Using password:yes)

@lparker - It looks like your data source line needs to be changed. You shared that your password line is structured like mmuser-acctpassword which is actually telling Mattermost that the password for mysql is mmuser-acctpassword.

Example structure:


You need to replace the <mmuser-password> with your password, like below:


Thank you for the response @Colton

I corrected the datasource, and ran “sudo -u mattermost ./bin/mattermost”. Received error below:

Failed to ping DB error 1044: Access denied for user mmuser’@’%’ to database ‘mattermost’

I ran " mysql -u mmuser -p", and was able to enter password and login. I then ran "use DATABASE mattermost; and received error 1044 access denied for user ‘mmuser’ to database 'DATABASE

@lparker - That’s better! It means it’s now hitting mysql. You may need to log into mysql and run the below:

grant all privileges on mattermost.* to 'mmuser'@'%';

I highly suggest typing the command instead of copy/paste as it traditionally interprets the single quote differently.

Is your database running on the same server at Mattermost?

I was able to grant the privileges, and yes the database is running on the same server

Can you get the output of show grants on MySQL also run FLUSH PRIVILEGES; and attempt to start Mattermost again.

Mattermost is installed but not accessible via browser

I followed all the instructions, and it’s up and running, and I can curl successfully.

However, when I go to the URL of my server http://myserverIP:8065 - nothing loads and I get a “The site can’t be reached” in Firefox or Edge. I cannot access mattermost from the web browser.

My SiteURL is showing

This sounds like a possible networking problem to access the server. You’ll want to confirm that your device can access the device where Mattermost is installed.

Everything is loaded one machine. The installation is isolated from the public so there is no traffic going out the internal environment.

That sounds like the issue is that Mattermost is listening for the URL to be viewed by the Mattermost server, instead of, say, localhost for a local instance, which you would be accessing from itself if that makes sense?

1 Like

Makes since, I change the URL to the IP of the server in the config.json file, and attempted to access mattermost server via browser with no success. Also, apache is not installed on the mattermost server as of yet.

I would highly suggest installing Apache, you need the ability to reverse proxy so you can setup the reverse proxy as well.