Mattermost noob configuration and Apache headache

Hello all, I am new to Mattermost therefore I was trying for the last couple of days to configure it properly but Mattermost plus Apache is giving me a very hard time. at first the installation went smoothly and I was able to configure mattermost with the default settings. No big issue there.
My problem started with Apache.
So here is the deal:

After setting up mattermost and get it running, checking that is listening on the default port I created an Apache virtualhost file with the following content.

<VirtualHost *:80>

After restarting apache and try to go to that url, despite mattermost server is running I got redirected to apache2 default page

The mattermost config.json is pretty on default settings except for

“ListenAddress”: “”,

This used to work at first but everything went downhill for me when I tried to use certificates and secure connection on 443
Now it doesnt matter what I do, despite mattermost server is running, and it is listening on 8065 i always get redirected to Apache default page

I tried to start from scratch but I had no luck and at this point my mind is exhausted dealing with the same.

another thing to note is despite that the mattermost server is running and listening

when I do curl the reply is that there is a problem connecting to mattermost

Can anyone point me on the right direction here. I am no new to Linux but all this ups and down had me exhausted


Hi @Ranma2264,

The Apache guide ( is maintained by community members and is unofficial - would you be able to post your feedback on this Github Issue and one of the community members will most likely be able to help with the issue you’re seeing:

Thanks to all, for some strange reason Apache was acting weird, despite default site was off and actually deleted, some remaining cache was displaying that page. All that I did was to clear the browsers cache and it was working on all the browsers I tested it. However now I am facing a new problem that I don’t seem to nail yet. I have been trying to configure reverse proxy and websockets on apache. I have tried a lot of configurations available on the forum and also scattering around the web, but no matter what I try, I get
WebSocket connection to ‘ws://’ failed: Error during WebSocket handshake: Unexpected response code: 500.

I took as an example the community apache guide but it doesn’t seem to work for me. I have tried a lot of configurations and combos but I always get a 500 response

Thanks for the support!

Hi @Ranma2264,

Please take a look at our troubleshooting tips on websockets here for help: