Permission inside the container

mkdir /.config permission denied

Steps to reproduce
run mmctl login command

Expected behavior
The auth file is created

Observed behavior


I installed mattermost 7.5.2 on openshift via the chart helm. The application works good but I have a problem if I want to use the mmctl.

To use mmctl I have to authenticate to the server. I tryed to do that from the container’s terminal from mattermost/bin

mmctl auth login http://localhost:8065 --name local-server --access-token mytoken

and I got Error: mkdir /.config: permission denied

I can’t change the permission with the chmod command.

What can I do ?

Hi 360 and welcome to the Mattermost forums!

mmctl can be downloaded independently and installed directly on your work computer, so you do not need to install it on the server.
The latest release (brandnew!) is 7.7.0 which can be downloaded directly from the GitHub releases page:

mmctl stores local configuration in a .config folder and therefore you should not run it directly in the container.
Depending on the configuration of your Mattermost server container, the so-called “local mode” could be enabled though and if this is the case, then Mattermost does not need to store authentication information and you can use the mmctl binary from within the container directly using socket authentication (no need to specify auth tokens then).
To see if this is the case, you could run the command as follows from within your container:

mmctl --local system version


Thank you for the answer. I used the application from my pc and it works good !