[SOLVED] Cannot access Mattermost v5.8.0-rc2 under subpath

After updating Mattermost from v5.7.1 to v5.8.0-rc2, I can’t access it.
It is caused by 404 error for some js files. It seems that Mattermost try to read js files from path without subpath, even though my environment is under subpath.


Additional Info

  • Server: Ubuntu 18.04 / Client: Chrome and Safari
  • Mattermost v5.8.0-rc2 Enterprise Edition
  • Using nginx as reverse proxy
  • I’ve tried to remove browser cache, restart nginx service, and restart Mattermost service, but it doesn’t fix this issue

Hi @kaakaa,

We have a ticket open here: https://mattermost.atlassian.net/browse/MM-14052 and the related PR here: https://github.com/mattermost/mattermost-server/pull/10252.

Let me know if these don’t seem related to the issue you’re seeing.


Thanks @amy.blais!!
That issue seems to be related to my problem. I’ll try new rc release including changes of the PR.

After updating to rc4, I can access Mattermost with subpath settings!
Thanks @amy.blais!

1 Like