[SOLVED] Custom Slash Command - Command with a trigger failed


We have an GitLab Server running with Mattermost integrated. In Mattermost there are two Custom Slash commands.
One is a custom for giphy bot, the other is a Custom Slash Command in our GitLab instance.
The custom GitLab one works. The command for giphy bot not.

Steps to reproduce

We have a running GitLab Instance with version 10.0.3 and Mattermost with version 4.2.0.
We have also running docker container that listens for Requests triggered by the /giphy command.

So we created a custom slash command with command trigger word “giphy” so we can show a random gif in channels or direct messaging. But it does not work.

Expected behavior

When in channel or direct message, then /giphy xyz should trigger the custom slash command and present a random gif.

Observed behavior

The error message is “Command with a trigger of ‘giphy’ failed”

Before version 4.2.0 of mattermost the slash command worked. It seems like it could be a problem with the Request URL. I have also found https://mattermost.atlassian.net/browse/PLT-7193 but I think that has nothing to do with the failure.
Somebody having the same issue? Maybe someone can help?

Hi @nugation
Looks to me that is a problem with the mattermost-integration-giphy, have you open an issue in their repo?

If you have access to the mattermost logs and you can set it to DEBUG mode perhaps it would be of help if you review and share those logs to see if we can have a little bit more detail on the issue at hand.

If anyone wants the solution: AllowedUntrustedInternalConnections in config.json needs to contain the hostname of the webhook.