[SOLVED] Empty response for slash command

Hi everyone,

Please need your help. I am pretty new in Mattermost and node-red and I am trying to create a slash command for mattermost using Nodered in Bluemix. I already make the slash command work with Slack, but when I tried the same with mattermost, I have the following response: “Command with a trigger of ‘wmax’ returned an empty response”. Checking the debugs nodes in Node-red show me the same for both cases (Slack and Mattermost).

Thanks in advance,


I don’t know if this will help you, but it helped me. Slack assumes some defaults, for example for the “response_type” it is assumed “ephemeral” (only to the user that initiated the command). I had some integration already with Slack and I was getting empty results in mattermost. As soon as I specified the response_type then it worked in mattermost.

Hi Nelson,

thanks a lot! it worked perfectly!


You are welcome. I think it is customary (I’m new here too) to put [SOLVED] in the subject so that others can see if this solution works for them.
Have a good one!

1 Like

done Nelson, thanks a lot!