[Solved] Enabling mattermost in gitlab 8.10 complains of role missing

I decided to try setting up mattermost with my gitlab installation and am not able to get it running. The only info I’ve been able to get from the logs is this message printed a lot.

panic: Failed to open sql connection pq: role “gitlab_mattermost” does not exist

Any idea why this is a problem? I’ve only set the mattermost external url.

I’ve found I can recreate this in this way:
Run docker container as such.

docker run --name gitlab-test -d -p 80:80 -v /host/user/gitlab-ce:/etc/gitlab gitlab/gitlab-ce:8.10.1-ce.0

Then change the gitlab.rb setting to set the external url to localhost and mattermost external url to

Stop and start the docker container again. Gitlab works, mattermost 502s with the above error in the logs.

I’m wondering if this is a bug in gitlab’s omnibus or a misunderstanding of mattermost setup.

Seems this was fixed in gitlab 8.10.2

@eyecreate, confirming this issue is fixed for you and can be marked as “solved”?

Yes, this specific issue seems to have been solved.

Thank you @eyecreate, I’ve marked this issue as [solved]