[solved] Mattermost server doesn't work after instalation.Failed to create index Error 1071

After the instalation mattermost can’t start and shows me this errors:

{“level”:“info”,“ts”:1553426325.7105906,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1553426325.71098,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1553426325.7225804,“caller”:“sqlstore/supplier.go:215”,“msg”:“Pinging SQL master database”}
{“level”:“error”,“ts”:1553426325.7914166,“caller”:“sqlstore/supplier.go:807”,“msg”:“Failed to create index Error 1071: Specified key was too long; max key length is 1000 bytes”}

Is there any solution?
CentOS 7.0, MariaDB 10.4, apache. PHPMyAdmin

Hi @francocool,

Which installation guides did you follow? What Mattermost server version did you install?

It was russian guide and i just solved the problem. I used MariaDB for previous installations of mattermost servers, but for new releases this does not work. I used the instructions on the official website and everything turned out. Conclusion - do not use MariaDB for mattermost.

Is this true? You can’t use MariaDB anymore? I got the same error trying to upgrade from 4… to 5.22

When you upgraded to v5.22, did you first upgrade to v5.0 in between?

Have you read all the important upgrade notes between v4.0 and v5.22 versions https://docs.mattermost.com/administration/important-upgrade-notes.html?

I didn’t upgrade to 5.0 first. I did read the “important upgrade notes” but I guess I missed something.

Turns out I was still using MyISAM as my engine for Mattermost tables. After running alter table ... engine=InnoDB things now work. Maybe it should say somewhere explicitly that only InnoDB is supported in Mattermost 5 (if that is true).