[SOLVED] Moving to new server not seeing teams and users

Doesn’t list any users or teams but it copied over all the channels and posts… I moved the /data folder from old server to new server per these instructions.

Anyone else seen this?

Steps –

#Stop mattermost on source
stop mattermost daemon
[root@mattermost ~]# systemctl stop mattermost.service
Verify mattermost status
[root@mattermost ~]# systemctl status mattermost.service

#Backup postgres database
pg_dump -U mmuser -d mattermost -h -f mm_backup.sql
#Pull down backup to laptop
scp -r money@1x.x.x.x:/home/money/mm_backup.sql .
#Pull down config.json
scp -r money@1x.x.x.x:/home/money/config.json .
#zip up data folder
tar -zcvf data.tar.gz /opt/mattermost/data
#Pull data folder down
scp -r money@1x.x.x.x:/home/money/data.tar.gz .

#Push up to the new server
scp mm_backup.sql money@1x.x.x.x:/home/money
scp config.json money@1x.x.x.x:/home/money
scp data.tar.gz money@1x.x.x.x:/home/money

#rename the old Data directory
mv -R data data.old
#untar and then copy data folder contents(if need be) into /opt/mattermost/
tar -zxvf data.tar.gz
mv config.json
psql -U mmuser -d mattermost -h -f mm_backup.sql

This restored the posts and channels but not teams and users???

Have you set the proper permissions to the data folder in case you’re not running it as root?

ls -la data

I seem to…

and …

Ah shoot didn’t realize the one server was on 3.5 and the new one on 3.8, gotta fix that tonight and hopefully that fixes it.

Looks like that was the problem, gotta learn to read the manuals better… I’m going to try it again though in the next couple weeks and see.

Thanks for your feedback @mathurin!

Seems your issue is solved for now but let us know how it goes when you do a re-run in a couple of weeks!