[SOLVED] NGINX Mattermost: 502 Bad gateway

Mattermost version: 3.5.0
Linux Ubuntu Server 14.04 x64

After installing it worked perfectly. After editing a config file:
“RestrictPublicChannelManagement”: “team_admin”,
“RestrictPrivateChannelManagement”: “team_admin”,

Restart mattermost:
sudo stop mattermost
sudo start mattermost

Shell tell me:
mattermost start/running, process 1627

But NGINX gives
Error 502. Log file of mattermost:

[2016/12/16 11:51:18 YEKT] [INFO] Loaded system translations for ‘en’ from ‘/home/mattermost/mattermost/i18n/en.json’
[2016/12/16 11:51:18 YEKT] [INFO] Current version is 3.5.0 (3.5.1/Wed Nov 23 19:43:58 UTC 2016/36f62c9e82350f58c902f64a5d3304872431ad41/none)
[2016/12/16 11:51:18 YEKT] [INFO] Enterprise Enabled: false
[2016/12/16 11:51:18 YEKT] [INFO] Current working directory is /home/mattermost/mattermost
[2016/12/16 11:51:18 YEKT] [INFO] Loaded config file from /home/mattermost/mattermost/config/config.json
[2016/12/16 11:51:18 YEKT] [INFO] Server is initializing…
[2016/12/16 11:51:18 YEKT] [INFO] Pinging sql master database
[2016/12/16 11:51:18 YEKT] [INFO] Starting 16 websocket hubs
[2016/12/16 11:51:18 YEKT] [INFO] Starting Server…
[2016/12/16 11:51:18 YEKT] [INFO] Server is listening on :8065
[2016/12/16 11:51:18 YEKT] [CRIT] Error starting server, err:open : no such file or directory

I tried to return the parameters:
“RestrictPublicChannelManagement”: “all”,
“RestrictPrivateChannelManagement”: “all”,

But it not give result. Restart the Ubuntu server, too.
Please, help me.

Must be:

“ServiceSettings”: {

“ConnectionSecurity”: “”,


Thanks for posting back @electrotehnik! Can you confirm your issue is fixed?

This resolves my issue as well.

that being saide previously I had " “ConnectionSecurity”: “TLS”,"

I am concerned by leaving this blank, is there a separate configuration we have wrong where it is reference the wrong file for enforcing TLS?