[solved] Server worked until I enabled TLS and LetsEncrypt

Server was working until I enabled TLS and LetsEncrypt. Whether using mobile app or web to access I can no longer connect to a working server. I could just edit the config.json back to 8065, but that would defeat the purpose of encrypted communication. I was wodnering if maybe the Dynamic DNS name was black listed so I ran: $ sudo certbot certonly --standalone -d example.com per the following thread https://forum.mattermost.com/t/issues-with-https-tls/5018/6

Currently at a loss as DNS and certificates are not my strong suit hence why I clicked use letsencrypt to handle it lol. I have allowed both 80, 8065 and 443 through the firewall so I know its not LAN issue as the server was working perfectly fine before TLS. Any insight would be grateful! Screenshot_20190414-132220

Hi @thaenatos,

Please take a look at this section on our troubleshooting docs: https://docs.mattermost.com/mobile/mobile-troubleshoot.html#i-keep-getting-a-message-cannot-connect-to-the-server-please-check-your-server-url-and-internet-connection.

1 Like

Thank you I will see what this reveals.

Ok found my issue. My apache2 would keep persisting after being disabled and now mattermost can listen on both 80 and 443 so TLS is working as it did before.

1 Like