[SOLVED] Unable to connect to Matermost server when secure connection is Enabled

my server(4.6.0) is working great and clients are connecting using http://myserver:8065

Now I’m trying to enable secure connection using TLS and Let’s Encrypt Key. It seems to be an easy task but I’m unable to connect to the server once those are enabled via admin console and after service restart.

Any toughts? Am I missing something?


Hi @RbDev,

Thanks for your feedback,

Perhaps this documentation will help?

This forum post might also help with troubleshooting?

Hi Lindy,

I’ve tried using the documentation but I can’t use port 443. This is being used by my webserver.

Mattermost Settings:
Port: 8065
Connection Security: TLS
Forward Port 80 to 443: False
Activate CAP_NET_BIND_SERVICE: No since this seems to only be needed for 443 port.
Use Let’s Encrypt: True
Service Restart.
Can’t log in.

The forum you linked seems to be related to specific TLS key. It should not affect Let’s Encrypt.

The log doesnt point any issues.

Let me know your toughts.

I really appreciate help here. I dont like to leave my messages unencrypted.

Let me know if you need any other info.


Hi @RbDev,

I’ve asked our engineers for help on this one and will get back to you as soon as I have their feedback :slight_smile:

@RbDev As mentioned in the documentation, there are 2 options to setup TLS. It seems setting up TLS from Mattermost server is not possible to you since you cannot setup Forward80To443 to true. In that case, I suggest you go on configuring NGINX with SSL. Before doing that, make sure to follow guide in configuring NGINX as proxy server for Mattermost.

In that case I will wait for the url subdirectory support implementation to have SSL done by my webserver via proxypass

1 Like