[SOLVED] Websockets not connecting because insecure Websocket endpoint


Websocket connections are not connecting, so new posts don’t show up unless I reload the page.

Steps to reproduce

Enabling SSL on nginx causes this problem

Expected behavior

When I enable SSL for nginx… websocket connections are not getting upgraded to wss. I get this error: was loaded over HTTPS, but attempted to connect to the insecure WebSocket endpoint ‘ws://mattermost1.nyc.deshaw.com/api/v3/users/websocket’. This request has been blocked; this endpoint must be available over WSS.

I follow configuration steps in the RHEL7 setup doc, but I can’t seem to get it to work…

Hi @marcchang - can you try Step 8 in the NGINX with SSL guide again to double check that the SSL certificate is set up correctly, and let us know what you get?

Thanks. Let me try playing around with the certificates.

I fixed this by changing http://fqdn to https://fqdn for the site URL in the System Console.

1 Like

@marcchang, thanks for posting back your solution! I’ll mark this solved for now.