Unable write the data in the file users

  1. The version of Mattermost - 7 3 0 in k8s, looks something like this Haproxy listens in 443 port for mm.domain.com and forwards to ingress ports of k8s. deployed with mattermost opertator
  2. A link to documentation
    So the problem looks like this:
    when i add HTTP_PROXY and HTTPS_PROXY for outside sites, such as push.mattermost.com
    everything else seems to fail, such as

{“timestamp”:“2022-10-14 07:30:55.497 Z”,“level”:“error”,“msg”:“Failed to sync plugins from the file store”,“caller”:“app/plugin.go:240”,“error”:“getPluginsFromDir: Error reading files from the plugins folder in the file store., ListDirectory: Unable to list directory., unable to list the directory plugins/: Access Denied.”}

{“timestamp”:“2022-10-14 07:31:27.328 Z”,“level”:“error”,“msg”:“Unable to write the file.”,“caller”:“web/context.go:117”,“path”:“/api/v4/users/xb3q7d8p9ffhzdf3me9c715gsh/image”,“request_id”:“x5x8t8j3zjdzxk81dihiqcn9ga”,“ip_addr”:“”,“user_id”:“wss4opt51j8pdypf5a1k4jn4mw”,“method”:“GET”,“err_where”:“WriteFile”,“http_code”:500,“error”:“WriteFile: unable write the data in the file users/xb3q7d8p9ffhzdf3me9c715gsh/profile.png: Access Denied.”}
Uploading images in chat also stops working
I tried adding NO_PROXY variable and variations of it, but it doesnt work
when i delete those variables - everything starts working except for pushes :slight_smile:

docs Using an outbound proxy — Mattermost documentation

solved it by adding my s3 to no proxy variable