Untrusted Certificate on Android Mattermost app

Mattermost version 5.25.1
Mattermost Android App - Updated to latest on July 15, 2020


I’m attempting to connect to our Mattermost Team Edition server through an Android app. My Mattermost server is hosted locally and we use HAProxy to provide certificates. I’ve configured HAProxy for our Mattermost and from my Phone Browsers and my Desktop Browsers I can connect through https with no issues securely.

But using the Android Mattermost app I receive an “Untrusted Certificate” error?

I’ve tested our cert using sslshopper and there are no issues found.

Is there something I’m missing when using the Android app for Mattermost? Any information this forum can provide for me would be greatly appreciated.

Thank you.

I’ll chock this one up to user error. I fixed my problem by reloading my haproxy config file. This has solved my problem with not being able to connect using my Android app.

Case closed. Cheers!


I have installed a Mattermost server on my QNAP nas, I have no problem to connect to it in local and external network via a browser. On the other hand, when I want to connect to it via the android application I have an error message: “Untrusted Certificate”
I have already tried restarting the server and reinstalling everything but it still does not work.

Can you help me ?

Hi, @MicMac

Can you please run the SSL Labs certificate test against your hostname and share the output here?

That might help us to understand the potential reason behind the issue such as an incomplete certificate chain (which includes root, intermediate, and end user) or other issues.

Thank you for your reply,
Here is a link to view a pdf containing the test results
In advance thanks for the help

Hello, @MicMac

You are welcome. I checked avietatechnique.ddns.net on my end and based on the result, I can see that the certificate is NOT TRUSTED which could be due to the following potential issues:

Can we start by going through each of them and verify the reason behind the issue you are getting on the Android app?

Thanks for the leads, the certificate issue is resolved, indeed I host Mattermost on my nas and the certificates for my nas were expired. However I have another problem now :unamused:

“Unsupported server version”

Hi, @MicMac

You are most welcome. The Unsupported server version potentially mean that you are running on an older version of Mattermost Server.

Can you please confirm that you are running on at least Mattermost Server 5.25 based on the mobile changelog documentation that we have here?

  • Server Versions Supported: Server v5.25+ is required, Self-Signed SSL Certificates are not supported unless the user installs the CA certificate on their device