Username incorrect after upgrade to 3.7.3

For feature requests, please see:

For troubleshooting questions, please post in the following format:


After upgrading to 3.7.3 Enterprise, all the usernames are incorrect.

Steps to reproduce

How can we reproduce the issue (what version are you using?)
Upgrade to 3.7.3 Enterprise.

Expected behavior

We are using LDAP/SSO. Username and uid is synced with samaccountname. After upgrading the username displayed in the client appears as something like: “asldjkalskdjasfhrfsdsdsdf” when original username was 19smith. Tried to do an LDAP sync without resolve. Tried changing the username sync field to displayname. This corrects the issue but everyone has an undesired username (john-smith).

Observed behavior

What did you see happen? Please include relevant error messages and/or screenshots.

See screenshots (conversation redacted).

Thanks @beckf for the report

We made a change to properly validate the usernames when creating users via the API:

However, it looks like it’s causing issues with LDAP usernames as you reported. We have a ticket to revert this change, which is considered for Mattermost v3.8.1:

Thanks @jasonblais . If it helps, most our usernames start with a number.

Sorry @beckf I forgot to reply,

3.8.1 was cut last week - we have since cut 3.8.2 which also contains the fix. You can download the latest version here: