Address forbidden when integating app


I am using the preview mattermost docker container version 7.2 i think with default settings except for the things that had to be changed according to the tutorial: Quick start guide (Go). I am trying to implement a golang mattermost app. The app already serves the manifest.json and works.

When trying to connect the app with following command
/apps install http http://localhost:8011/manifest.json
to the mattermost server i get following error:

Get "http://localhost:8011/manifest.json": address forbidden, you may need to set AllowedUntrustedInternalConnections to allow an integration access to your internal network

I have set AllowedUntrustedInternalConnections to: localhost

Thanks in advance

Hi wilma and welcome to the Mattermost forums!

It could well be that localhost resolves to an IPv6 address or to an internal or public IP (depending on the content in your /etc/hosts file). Can you, just for testing purposes, allow in the AllowedUntrustedInternalConnections configuration option explicitly just to see if it would work when everything is whitelisted?

I changed it like you suggested but it still throws the same error

After a container restart it worked. (don’t know why i didn’t think of this)

Because the Mattermost Server runs inside the container, the IP of the Gateway had to be whitelisted instead of localhost , in my case