Admin account not being created

I’ve read and rearead the install documentation 20 times now and I just can’t get past this.

I have followed the instructions to the letter and I am still stuck.

When I login to Mattermost via my web browser the first time it asks me to register, which I do, but then the user is not given admin privileges (as the documentation says it will).

When I login I get the message:

No teams are available to join. Please ask your administrator for an invite.

I have tried using the CLI to give my user admin privileges and I have tried manually creating a new team but I am getting nowhere.

Why would my initial user not be getting admin privileges?

Hi, @gnicol

Allow me to help you out with this. First things first, can you please share the specific documentation guide you referred to when installing Mattermost on your end? Perhaps you can also share a little bit more on the environment that you are deploying the Mattermost server too.

Additionally, I would also be interested to see the data structure of the first user created. Can you please run the SQL query and provide me with the result:

SELECT Id, Username, Email, Roles FROM Users WHERE Email = "<email>";

The specific column that we will be interested to look at would be Roles where it should tie to the following value:

Roles: system_admin system_user

Keep me posted soon.