Can't create and initial team / user

I am installing Mattermost on on RHEL 6.0 following this guide:

I’ve reached the Finish section here:

On Step 1 it says to navigate to Mattermost server I installed to create the initial user. When I navigate to that URL I get the login page and do not see a place to create a user. Did I miss a step?

Hi @tradecraft1,

If you’re the first user it should ask you to create an account. Can you check if your Users table in the database is empty? Also for my information, which version of Mattermost are you running?

You should be able to remedy the problem using the command line interface options that we provide.

Thanks. I will check the table now. I am running 3.1. I noticed that I can’t add a user via the command line. When I run the below command it just hangs and doesn’t return:

./platform -create_user -email="" -password=“XXXXXXXXXXXXXXX” -username=“blah.blah” -role=“system_admin”

I couldnt find any errors in the mattermost.log or /var/log/syslog.

Hmmm can you try creating the user with:

./platform -create_user -team_name="name" -email="" -password="mypassword" -username="user"

and then try updating them to system admin with:

./platform -assign_role -email="" -role="system_admin"

No it just hangs on the first command.

bash-4.1$ ./platform -create_user -team_name=“name” -email="" -password=“mypassword” -username=“user”
[13:49:10 EDT 2016/06/30] [INFO] ( Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’

I take that back. This time after a couple minutes I get this:

[2016/06/30 13:51:06 EDT] [EROR] SqlTeamStore.GetByName: store.sql_team.get_by_name.app_error, name=name, sql: no rows in result set

I’m looking at the SQL side now.

I think that is saying that the team does not exist. Does the team need to exist before you can assign a user to it?

Oh, maybe try making a team first:

./platform -create_team -team_name="name" -email=""

There used to be a dependency on creating a team before a user but that was removed in 3.0 but it looks like we didn’t update the CLI to reflect that

I tried this:

./platform -create_team -team_name="TEAM" -email=""

and got this error:

[EROR] Team.IsValid:, id=mfaxfs15xf8ixmndbd91jnpwgo

Is it complaining about valid characters?

I figured it out. The team name cannot start with a capital letter. Something is awry with the input validation.