Blank webpage and "Uncaught TypeError: window.setup_signup_team_page is not a function"


we have already installed the version 1.4 and using it without big problems.
I tried to upgrade from 1.4 to 2.0 without any luck.

My process was the following:

  1. I stop the mattermost service
  2. I backup the database and the configs
  3. I decompress the new tar
  4. Copy the backed up config files back to the Config folder
  5. Start the service
  6. Restart nginx

Then if i try to access the webpage i get an almost blank page without login form. The logs folder is empty. The only clue i have that all the browsers (Chrome and Firefox) logs an error to the developer console. It says: “Uncaught TypeError: window.setup_signup_team_page is not a function”.

And there are some other errors where the application tries to download non exsisted js libraries from our server and These libraries are there but with a different version number: 5950.

If i revert back to the old 1.4 version (with the same process i mentioned above) everything works fine. So now we stucked. What can be the problem? Do you have any idea what should i try? What other information should i provide to investigate this problem? (I am planning to do a clean install in a different location if i will have time to do that).

Any help appriciated.

Hi Kemy, appreciate the report, not sure what it is, is anyone else from the community hitting this?

Adding a GitHub issues thread where others are hitting a similar issue with v1.4:

Anyone from community hit this error message and figured out the solution?

When we tested the configuration internally it worked.

@Kemy, can you share which OS you’re using?

Thank you for your response. We use Ubuntu 15.04.
I didn’t have time to try a clean install but i should do it in the near future because the team can’t wait for the upgrade. :slightly_smiling: