Cannot stop a run of an archived playbook

I created a playbook and archived it. But a run has not been ended and is sending me notifications. There does not seem to be a way to stop the run, because the playbook has been archived.

Steps to reproduce
If I remember correctly, I created a playbook from a template called “service outage incident” to play around with it. To stop the playbook from sending me notifications, I archived it. Unfortunately, the first run of the playbook is not stopped and is still sending me notifications.

Expected behavior
The playbook should not send me notifications when it is archived.

Observed behavior
I cannot stop an archived playbook sending me notifications. I am also not able to “unarchive” the playbook to stop its runs.

What Mattermost server version and Playbooks version are you using?

I am using Mattermost as a client and the desktop client version I use is the version for MAC 5.0.2 (
I think the server version is as follows:
Mattermost Version: 6.3.3
Database Schema Version: 6.3.3
Database: postgres

I don’t know how to get the Playbook version as a client. Could you tell me how to achieve this? Thanks.

@jesse @crspeller Is this a new issue or is there a ticket for an issue like this already? I did some searching in Jira and couldn’t find.

Hi @dschaehi! I’m sorry you’re running into this edge case. In the March release of Playbooks, you’ll have an option to browse even archived playbooks.

In the mean time, can you confirm if the run in question that continues to notify you shows up in the list of runs at /playbooks/runs? If you can view the run, can you use the “Go to channel” to find the Playbook Run RHS in Channels, and use the “Finish Run” option below your checklists?

In general, we don’t expect that archiving a playbook should necessarily stop outstanding runs, but we definitely need to make it easier to navigate.

Let me know how far you get in the steps above – I’d be happy to help you work through next steps to get this resolved.

Hi @jesse,

Thanks! By clicking on the “Go to channel” button of the playbook I was led to the default channel of the server, but the channel does not show anything on the RHS.
It is possible that I created a temporary channel for the playbook and archived it with the Playbook, so the channel does not exist anymore.
Perhaps this is indeed an edge case… Hope we can find a solution as the constant notifications are quite irritating.

Hi @jesse, do you have perhaps any updates regarding this issue? Thanks.

Hi @jesse, I could solve the problem by asking the admin to enable “Allow users to view archived channels” and then following your instruction. Thank you for your help.

Hi @dschaehi! Thanks for sharing your final solution – I’ll note that as a workaround until we have a better solution in-product.