"Playbook Not Found" for me, but visible to colleagues

I created some playbooks as a test in the app (5.2.1), and they all worked fine.
At some point I clicked on the star in the details page for one of the playbooks thinking it would add it to some sort of favorites list.
Immediately the playbook disappeared - I was left staring at a blank Mattermost screen.
I went to back to ‘Browse Playbooks’ and I could still see the list of all the playbooks, but when I click any of them, it says “Playbook Not Found”.
This happens in the app and from a web browser. I’ve tried clearing cache and reloading.
My colleagues can still view the playbook and its details fine.
Any advice? Thanks!

Hi beamboy and welcome to the Mattermost forums!

Did you try to access the playbooks using the webbrowser to rule out that your account is having some issues? If you are also unable to access the playbooks using a browser, we need to dig a bit deeper - if it’s just the app that’s not working for you, we can continue our troubleshooting on the app.

Hi,
Yes, It is the same problem on both the app and the web browser unfortunately.
Thanks for looking into this issue

Sorry, I just recognized that you already said that the webapp behaves identical - my bad.
Anyways, let’s dive into the database now to see what’s going on here.

Do you recall the name of the playbook?
If so, you could try to run the following query in your database, which will list all the available playbooks (here’s an example from one of my systems):

mattermost=# select id,title,deleteat from ir_playbook;
     id     |                title                |   deleteat
----------------------------+-------------------------------------+---------------
 crypticid1 | Veronika                            |             0
 crypticid2 | product build playbook              |             0
 crypticid3 | Incident Collaboration Playbook     | 1616404135729

In this example, the last playbook has been deleted. Most likely also not the reason for your problem, because others can still see it.
You could also additionally query for the teamid attribute in this table and verify that the playbook and you are actually in the same team, which could also be the reason why your colleagues are seeing it and you don’t.