Clean Install of Mattermost, close but no cigar!

Hello everyone, I have installed mattermost server on a clean installed server running linux ubuntu 20.0.4 with no errors, the server has a public IP and no other program or anything installed, I followed a guide from the link here

Steps to reproduce
How can we reproduce the issue (Mattermost 6.4.0 )

Expected behavior
After the install is complete I expect to navigate to the IP on the server and prepare the configuration for workflows and future users

Observed behavior
What did you see happen? When I navigate to the IP of the server without inputting a port # I get a “bad gateway” from NGINX, I have tried several variations of the URL and also both sets of ports. No luck. I also have only one error in the whole process of install, I will share a screenshot of it here!


I would not say I am “new” to linux, I used to work with it a lot back in the day, but I am seriously rusty, I may have missed something, but the install felt solid. Also since this server has one function and one function alone and has not even been configured to work (mattermost does not work) I am open to creating remote credentials for anyone who wants to help try to figure it out, this will when setup right replace slack for a team of 5 sales reps and 50 technicians, I am hoping its something silly!

thanks for any help!

Anyone have any thoughts on this, or a forum that might be more active?

Hi @wngmattermost and welcome to the Mattermost forums!

The application server is not starting up and we need to check the logs for the reason, but in your screenshot, the logs are truncated. If you followed the default installation instructions, the full log should be available at /opt/mattermost/logs/mattermost.log - can you look at this file and post the last 100 or 200 lines of it here so we can have a look at the reason?

Also, is this a new install and if so, why are you installing 6.4.0? This is a pretty old version.


APologies I followed an out of date guide, I have nuked the server and reinstalled with 7.10.2 now, still does not work however, Ill get the log as you requested, be aware NGINX does not work either, LAMP is installed on the server however

nginx is not able to start because the ports it wants to bind to are blocked by a different application. Since you’re saying that this is a LAMP system, I’m pretty sure that Apache is blocking them.
You said that this server is only for Mattermost, so please nuke the whole LAMP setup on it, you don’t need it to run Mattermost (no apache, no mysql and no PHP necessary).
For the database, you should go with PostgreSQL.

It might be easier for you though to go the Omnibus route, so all you need is a fresh Ubuntu server with just the minimal software installed and after that, follow this installation guide:

It will automatically download and install Mattermost, the database server and nginx as a reverse proxy in front of it and is the easiest method of setting up Mattermost in my eyes. Also upgrades are super-easy, since all you have to do is just run apt update && apt upgrade in the future.

Wow you are a lifesaver, I seriously need to go back to Linux school! I used to know so much!

Also I want to use this server to run the mailserver, but since those ports are not 80 or 8065 I think that should work out, Ill nuke it! Ill keep you updated!

What mailserver? The one Mattermost needs to send out e-mails or something more sophisticated also hosting mailboxes, etc.?

We are still reviewing technologies, we looked at citadel, but as full featured as it was we think its a bit “old school” cool looking though, I just need something that can handle 500 mailboxes, basic webmail, imap from outlook and mobile devices and such, and also I need one that can potentially setup mailboxes with a script, something that might be able to do say 100 boxes at once?

Any reccomendations?

A lightweight but fairly solid gui on the backend would be helpful as well

Sorry, no recommendations for that, I’m usually administering my mailservers from the CLI and the ones at work are integrated into our cloud management platform which provides the GUI and the API for that, but I think that’s a bit off-topic here in the Mattermost forum :slight_smile:

All good, we will muddle along

Here is something that IS on topic!

This looks like you did not follow the first step in the documentation to set up the repository. Can you confirm that you did run this command?

curl -o- | sudo bash

DOH sorry again, I warned you I am really rusty!

I like to be able to paste but I am using a server without a GUI right now, Ill let you know AFTER I follow all the directions

You can login to the server via SSH from your client and that way you can then paste the commands. SSH should be set up on all linux systems automatically, so just run any SSH client on your computer to connect to the IP of the server, login with the credentials and you can administer it easily from there (including copy&paste support).

curl -o- | sudo bash

Is that a pipe?, after I run

curl -o-

I do apt update then apt upgrade, and i still cannot locate omnibus on that server

I am running Putty now, and it indeed does have a paste function, however still hitting errors

Yes, that’s a pipe - interesting, that add-apt-repository is not available on your distribution.
Can you please post the output of lsb_release -a and if that’s not working, then plase post the output of cat /etc/os-release.

To add the script add-apt-repository, please run the following command:

apt install software-properties-common

I ran the apt command

here is the output

The forum is limiting my link output (like most forums nowadays) so here is a screenshot

OK, then try this command again, please:

curl -o- | sudo bash

And yes, that’s a pipe.

someone here works with the mattermost repos, you fixed something, bight purple screen

OK, then it’s asking you for something and you need to answer the questions (this is the normal dialog interface for asking questions during package installation).