Error during Mattermost Omnibus installation

During deployment of Mattermost with Omnibus installation I get error in the final check and cannot proceed forward.

Steps to reproduce
Installation made remotely on AWS EC2 t2.micro running Linux Ubuntu 20.04LTS.
Installing Mattermost server using Omnibus. Using command sudo apt install mattermost-omnibus -y

Expected behavior
During the final check im expecting output Play Recap with 0 fails.

Observed behavior
During Generate SSL Certificate task the task and rest of installation fails. Output here in Pastebin link. I tried to use alternative command sudo MMO_HTTPS=false apt install mattermost-omnibus and that worked as expected from that command. After using this command i ran the server without any major issues. But I cannot work out why I can’t make it work with the primary command.

P.S. I’m new here and not used to post in forums so I apologise for any mistakes.

Hi Patrick and welcome to the Mattermost forums!

The command without https requires your site to be publicly available due to how Let’s encrypt works, so as you can see in the error message, the ansible playbook part of the omnibus installation tries to generate a free Let’s encrypt SSL certificate and in order to verify this certificate, the Let’s Encrypt Servers need to be able to reach, which is not the case right now.
You will need to open up your firewall and allow port 80 at least temporary for the installation to finish.

Detail: Fetching", "", "   Timeout during connect (likely firewall problem)"

The ip in this case is one of the Let’s Encrypt verification servers and it ran into a timeout when trying to access

Hi @patricktsidina ,

just trying to follow up here - were you able to resolve this issue?