Error while attempting to convert service.mattermost.read_only to appropriate type: "" is not a valid boolean value

Summary
It’s my first time trying to deply Mattermost and I’m facing some Issues to run it

Steps to reproduce
I’ve already installed docker and all the dependencis, I’m following this Deploy Your Self-Hosted Mattermost Server | Mattermost and at the last part with sudo docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml up -d I’m facing the Issue that you could see in the image attached

Expected behavior
App running

Observed behavior
See the screenshot

Hi Junkboy and welcome to the Mattermost forums!

I’m not really sure, but to me it looks as if you do not have a .env file in your current directory. Did you maybe omit the step cp env.example .env in the documentation?
Also: You’re already logged in as root, so sudo is not necessary.

Thank you about the “sudo” is not necessary I just try it and yeah you’re right I’m new with this hahaa.

About the .env I already have one but yeah you’re right I omit that step in the documentation because the repository at GitHub - mattermost/docker: Install Mattermost server via Docker already has the .env file as an example and thats why I omit that step.

So… I have that .env file but its not working I’m facing that issue

Let me see what we have here. Please run the following commands and share the outputs:

cd ~/docker
ls -lhtra
grep POSTGRES_IMAGE_TAG .env
docker-compose --version

Youre complete right I just run cp env.example .env and now… it seems to be working, you could see:

But now I dont know where I should see the portal of mattermost, In the .env file I set the domain as admin.mydomain.com but I think that I should do a CNAME with my domain or something right? (I dont know if I’m explaining my self right but now that seems to be working I dont know where I should see the app running)

Told you the .env is missing :slight_smile:

Mattermost should now run on localhost:8065 from the server perspective, but I’m pretty sure it doesn’t because your docker-compose version is too old. You will need at least 1.26.0 for that to work, but the good thing is, there’s an easy upgrade.
So please stop your containers again, uninstall your distribution’s docker-compose package and download the latest version from the GitHub repository:

# Stop docker containers
docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml down

# Please make sure that no other packages are being uninstalled with this step, if unsure, please post the 
# list of packages it's trying to uninstall so I can have a look
apt-get purge docker-compose                      

# Download new version and install it
wget -O /usr/local/bin/docker-compose https://github.com/docker/compose/releases/download/v2.10.2/docker-compose-linux-x86_64
chmod 755  /usr/local/bin/docker-compose

# Clear the shell's path cache
hash -r

# Verify that the binary is executable and that you can see the newest version
docker-compose --version

Dude I really appreciate you taking the time to explain me in such detail, you are amazing!!!

About the steps that you mention I already do it and its not working I will do it again and share with you an screenshot

OK, your session has the old path to docker-compose still cached, sorry, forgot about that.
You did everything right, just type hash -r into the console, after that, the command docker-compose --version should work and display the version 2.10.2.

Dude you’re all right now it’s working and ‘localhost:8065’ takes me to register as a new user!
With this I will figure out how to handle my domain to redirect here

I really appreciate your time, now I’ll start trying to explore this installation

By the way, is there any documentation about, for example, how to give an admin role to a user to manage the work items in the portal?

and some documentation about how to customize the portal (if possible) for example with your own logo etc.

Once your logged in, click on the menu button in the top left corner and choose “System Console”. This is the admin console for Mattermost and is pretty much self explanatory, click around a bit to get familiar with it.
There’s lots of online documentation about the settings you can configure there.

For the two things you mentioned, to upgrade a user to a system admin, click on “Users” in the “User Management” section of the system console, search for your user account and on the dropdown at the right for the user row, click on “Manage Roles” and choose “System Admin”.

Custom logos and colors can be configured in the section “Site Configuration” under “Customization”.

Perfect, last question, I’m worried that I was the first registered user, he gave me the system admin role, this only happens automatically I imagine, because I’m the first registered user? the following users would register and become just members right?

Thank you again a lot of work to do, a lot to learn, thank you very much!!

Yes, this assumption is correct. The first user is admin, all others will only be normal members and will not have any option to upgrade themselves, only the system admin can do so.

1 Like