Failed (?) upgrade to 7.9

I received the notification of the release of 7.9 yesterday in our Mattermost installation, and since I can no longer seem to find the page in the docs with the latest version listed, I grabbed the 7.9.0 tarball. I have two instances running on two identical VPSs (Ubuntu 20.04). When doing upgrades, I typically open both CLIs and paste in the commands from the upgrading doc simultaneously. All seemed to complete without issue.

However, when I went to restart both of them, one started right up, but the other failed. I stopped that instance again and tried to restart it, but systemctl status shows only activating for perhaps 20 minutes. I then found the 7.9.1 tarball and tried to upgrade to it with the same results. Eventually, I simply replaced the active install with the 7.8.0 backup and started it up without issue.

This morning, when looking throught mattermost.log in the failed upgrade folder, I see lots of these:

{"timestamp":"2023-04-13 18:46:10.510 -04:00","level":"info","msg":"Pinging SQL","caller":"sqlstore/store.go:240","database":"master"}
{"timestamp":"2023-04-13 18:46:10.511 -04:00","level":"error","msg":"Failed to ping DB","caller":"sqlstore/store.go:250","error":"dial tcp [::1]:5432: connect: connection refused","retrying in seconds":10}

I’m not sure what to make of these. MySQL is up and answering, and nothing about it or the various usernames has changed. Any ideas as to what might be happening?

Hi @Jestre and welcome to the Mattermost forums!

You’re saying “MySQL is up and answering”, but your Mattermost insatllation tries to access a PostgreSQL server (port 5432). If you’re in fact really using PostgreSQL and you confused it with MySQL in your posting, then the error message indicates that your PostgreSQL server might have some access restrictions or is not running at all. Since you’re talking about tarballs, I assume you’re using the binary deployment method, right?

With regards to the download links: You can find them on the Downloadpage where it reads “tar installation guide”. They do always follow the same scheme:

# Enterprise Edition

# Team Edition

The most recent version is 7.10.0, just replace the Xes with the version you want to download.
You can also use the latest shortcuts:

If you’re in fact using MySQL and the system is trying to access a PostgreSQL server, this indicates that the system is running with a wrong configuration file. Please check your environment variables (if you configured it using environment variables) or that the path to your configuration file is correct and that the config.json is readable for the server. The startup logs might give additional information if it’s unable to find/read the config.json.