HashTags with dash doesn't work properly


I wrote posts with hashtags.
#qa-xxxx #master-xx

then, I click the hashtag for searching posts.
it doesn’t work.

other hashtags with dash works properly.

with double quotation, #qa-xxxx , #master-xx work properly.
#qa-xxxx” “#master-xx

Is there any keyword?

Thanks for reading.
if any possible solution, please answer to me.

#searching #hashtags

@aksjm2 What Mattermost server version are you on? What devise and OS are you on?


Server Information

  • Mattermost Version : 5.13.0
  • Database : Mysql
  • OS : CentOS 7

Client Information

  • Mattermost Version : 4.2.3
  • OS : Windows 10 pro.

Hey there @aksjm2, what happens when you click on the hastags that have a dash in them? Does it try searching but is unable to find any results? Or does the search just not happen at all?

I tested this with version 5.15 of Mattermost, and version 4.2.1 of the client, and I got this result when I clicked on #qa-xxx :

(don’t mind the drawing part that was from another test)

@joewai.tye, here is ther results. Thx for your testing.

when i clicked #master-xx

Search Result : No Results Found. Try Again?

#qa_manual, #master-vn, #qa_xxx has same result.

@aksjm2 Are there any Mattermost log errors or console errors that you see when this issue happens?

There’s mattermost management team in the company, so I don’t get the logs :(.

client debugging tool doesn’t have error log.

I think there are some error in server side…

I’m sorry to say that…

Hi @aksjm2, I did some more testing with a similar version of Mattermost as the one you are using (5.13.1), and indeed I could not search for any hashtags that had a dash in them. On the other hand, regular hashtags worked just fine.

On the other hand, my previous test that I included in my screenshot was from 5.15.1. I believe that this may have been a bug, but it has been fixed in the latest version.

Your organization may need to upgrade Mattermost to fix this issue.

1 Like