How I can remove Preview Mode banner?

I don’t like to use email notification. How I remove this banner “Preview Mode: Email notifications have not been configured”?

Hi @jpkorhonen, would you like to turn off email notifications for your entire server or just for yourself?

In Account Settings > Notifications > Email Notifications you can disable email notifications for your personal account even if they are enabled for the server. In order to remove the banner, email notifications have to be enabled for the server via the System Console > Notifications > Email.

2 Likes

Thanks Eric! What to do if I’m logged in as admin and it says that “not enabled by system admin”? https://i.imgur.com/gi79HaI.png

Hi @kaspar,

You can enable email notifications via System Console or config.json: https://docs.mattermost.com/administration/config-settings.html#email

1 Like

If we really want to disable email notifications seems there no way to do it?

Hi, @renchili

I would assume that you are not using email notifications completely in the Mattermost Server. Just ensure that the following line in your config.json is set to false.

ahmaddanialmohammad@ubuntu:~$ cat /opt/mattermost/config/config.json | grep "SendEmailNotifications"
        "SendEmailNotifications": false,

Or from the UI:

1 Like

this will get the Review Mode banner, how I can let it disappear?

Hi, @renchili

Based on the documentation that we have here, you need to set the Enable Preview Mode Banner to false . That should do the trick.

Let me know how it works on your end.

this is very ridiculous that disable email notification and then show that is under preview mode
the preview mode is absolutely useless

And the email notification is a mess of bugs. under 5.19 everything around the email notification are wrongly realized.