How to set helm chart to deploy team edition?

I am deploying from the helm chart here:

It uses this image here:

Both clearly say team edition, and in the values file there is no config flag to select team edition. When I deploy though I see this in the logs: {“level”:“info”,“ts”:1552325998.6409657,“caller”:“app/server.go:195”,“msg”:“Enterprise Enabled: true”}

How do I set this to false? I checked my values, and I don’t appear to have enabled any Enterprise features.

Any help would be greatly appreciated.

Hello, @bcxxbc

Before digging deeper into this matter, can I please check if you went through the steps explained in the How to install Mattermost Team Edition Helm Chart in GitLab Helm Chart deployment, especially on the deployment part here?

helm upgrade --install --name mattermost -f values.yaml stable/mattermost-team-edition

For the record, I have the same line on my logs when I deployed my team edition on Ubuntu 16.04 as well. So, I would think that the full enterprise features is tied to the license key purchased though the logs show that the Enterprise Enabled parameter is enabled to true:

ahmaddanialmohammad@ubuntu:/opt/mattermost/logs$ cat mattermost.log | grep "Enterprise Enabled: true" | wc -l

I will check with the team if that is the case. As of now, can you confirm if the Mattermost deployment is running properly on your end nevertheless?

1 Like

Ya I deployed it fine, but it doesn’t say it is team edition anywhere in the gui and the only reference to either is that in the logs. I did find this in docker hub, so maybe this is an issue that you guys should correct:

@cpanato Is this something you could help take a look at?

I used that alternative docker container I linked, and now it shows as enterprise enabled false and loads Team Edition as expected. Maybe you guys can put the changes from the unsupported container into your builds going forward to force Team Edition like he has?