Https with apache2 not working


Mattermost works fine with http, but can’t get https to work with mattermost

Steps to reproduce

Mattermost Version: 5.0.0, http…:8065 works fine, now needed to make it https using lets-encrypt certificate, spent a lot of time searching, found two options with instructions:

  1. Configure mattermost config.json with TLS, 433, use letsencrypt, forward 80 to 433. The problem here is matermost doesn’t start because 433 is used by apache (have another web application bugzilla using https on same machine), instructions from

  2. Configure apache reverse proxy for mattermost, following the instructions for virtual host settings. The issue here is that chrome says invalid site name in certificate because it trying to use bugzilla certificate. Instructions from

Expected behavior

Can you use https for mattermost with other https virtual hosts, or need dedicated machine for mattermost to work with https?

Observed behavior

option 1: mattermost exits
option 2: https request can’t find the right certificate

It works now, used “apache2ctl -S” and it showed *:433 missing for the site in the list and that is why it was using the default certificate.

Replace *:433 with ip:433 and that worked