InstallationProblem using Docker-Compose on Synology DS218+ [solved: through workaround]

Hey guys,

I’ve tried to install the latest Mattermost team version on my DS218+ Synology using this tutorial:

It all works well until the “docker-compose build” command, where I get the following exit:

ERROR: Service 'app' failed to build: The command '/bin/sh -c mkdir -p /mattermost/data /mattermost/plugins /mattermost/client/plugins && if [ ! -z "$MM_BINARY" ]; then curl $MM_BINARY | tar -xvz ; elif [ "$edition" = "team" ] ; then curl$MM_VERSION/mattermost-team-$MM_VERSION-linux-amd64.tar.gz | tar -xvz ; else curl$MM_VERSION/mattermost-$MM_VERSION-linux-amd64.tar.gz | tar -xvz ; fi && cp /mattermost/config/config.json / && rm -rf /mattermost/config/config.json && addgroup -g ${PGID} mattermost && adduser -D -u ${PUID} -G mattermost -h /mattermost -D mattermost && chown -R mattermost:mattermost /mattermost / /mattermost/plugins /mattermost/client/plugins' returned a non-zero code: 1

I’ve tried to google and search the forum and ask some avid linux friends but to no avail. I’ve heard that it is generally possible to install mattermost-server on synology so can anybody point out the solution for my problem?

Hi @DMT :slight_smile:

I don’t know if it is possible to use Docker on Synology. But if you can, I guess you should be able to deploy Mattermost :slight_smile:

Do you have a more detailed log error ? You should have a long log output during the build, and a more precise message should be present in it. The one you paste just tell that one command during the build failed.

1 Like

Hey @pichouk,

thanks for the reply and sorry for me not answering so long.
I’ve tried everything I could but couldn’t make it run. I didn’t lookup further logs so can’t say I’ve found any more useful information.

My solution for the whole problem was basically to conduct a workaround through installing the virtual machine manager and installing additional 8GB of Ram to make it work.

I have installed mattermost on the ubuntu VM successfully and didn’t go back to check whether the RAM (had only the pre-installed 2GB) may have been the issue with the docker-compose command but it could be. Couldn’t make any VM run on the 2GB of rum while it runs very smoothly now with 10GB!

Hey @DMT, @pichouk,

Found this issue as I was having the same problem on my Synology DS918+. The error is on the line

addgroup -g ${PGID} mattermost
&& adduser -D -u ${PUID} -G mattermost

I replaced the variables with the hard coded values from the ARG declaration. I don’t know what causes the error, perhaps an old Docker version on the Synology (17.05). Either way - by replacing with static values I got it running.

So, this works,

addgroup -g 2000 mattermost
&& adduser -D -u 2000 -G mattermost

Thank you @vktr, it works. I edited the file “Dockerfile” from “app” folder created by installation as you suggested.
Another problem I had with connecting the database. I stopped the container and I added manual ports (ex. 5433 external and 5432 internal, then I changed the values in docker compose file.

I wonder if anybody tried to link mysql version of mattermost with internal mariaDB. I couldn’t do it. The postgres version is fine, consume less memory.