Interactive Messages not working


From doc over here i tried to create interactive message - but no luck.

mattermost version
Version: 5.5.0
Build Number: 5.5.0

Steps to reproduce

  1. Create Slash command with API call to return json with list of options

2.1) First try - API response return json body
{ "attachments": [ { "text": "Select segment to add", "actions": [{ "name": "Select an option...", "integration": { "url": "http://some_url/mattermost", "context": { "action": "setSegment" } }, "type": "select", "options": [ { "text": "Option1", "value": "opt1" }, { "text": "Option2", "value": "opt2" } ] }] } ] }

2.2) Second try - try to use responseUrl URL to send message with attachment (same data)

  1. Message creates; response gives 200 (if we use responseUrl)

  2. get message with attachments but without actual select

Expected behavior

UI should show something like this

Observed behavior

Instead i get this

Message with attachments, but actions are not working.(

Hi @taras.budzyn,

Did you have a chance to take a look at the troubleshooting section in the doc:


I thought that tried both variants when making API calls((
It was stupid from my side to not check Troubleshooting section for this.

Thank you, Amy, to point me to this. Will close this thread then.

No worries @taras.budzyn, it’s not stupid!