Issue with running "make run-server" during Mattermost development setup

Issue with running “make run-server” during Mattermost development setup

Steps to reproduce

  1. I’m new to Mattermost and open-source contribution.
  2. I followed the manual guide for setting up the development environment: Developer Setup Guide.
  3. I reached the step “cd server.”
  4. When I ran the command “make run-server,” the following output was displayed:

Expected behavior
The “make run-server” command should start the Docker containers and successfully initialize the development environment.

Observed behavior

following as the output on terminal after runniung “make run-server”

Creating a file
rm -f
go work init
go work use .
go work use ./public
MMCTL already exists in bin/mmctl, not compiling.
Starting docker containers
docker-compose rm start_dependencies
No stopped containers
go run ./build/docker-compose-generator/main.go mysql postgres inbucket  minio | docker-compose -f docker-compose.makefile.yml -f /dev/stdin  run -T --rm start_dependencies
[+] Running 3/0
 ✔ Container mattermost-mysql     Running                                                                                                                                                             0.0s 
 ✔ Container mattermost-inbucket  Running                                                                                                                                                             0.0s 
 ✔ Container mattermost-minio     Running                                                                                                                                                             0.0s 
[+] Running 1/1
 ✔ Container mattermost-postgres  Started                                                                                                                                                             1.9s 
Waiting for mysql to listen on 3306...
Service mysql:3306 did not start within 300 seconds. Aborting...
make: *** [Makefile:254: start-docker] Interrupt

getting the same error , did you find any solutions ??

1 Like