Mattermost and Jitsi on one server: Always redirecting to mattermost

Hey there,

I tried to install mattermost and Jitsi. Everything is working fine and Jitsi is also working. But now I want to change the preset Server to, where the Jitsi server is running on.

When I first setup Jitsi under meet… I can easily access it. But when I install Mattermost on my Linux Server, it always redirects me to, no matter what domain I type in.

Is the mattermost config the reason or nginx?


Edit: For understanding, both domain are pointing to one server, so both services are installed on one server.

1 Like

Hi, @timowevel

With reference to the statement here:

  • In terms of NGINX, you need to check your server_name in the /etc/nginx/sites-available/mattermost file.
  • In terms of Mattermost, double check your SiteURL in your UI or config.json file.

Hey, thanks for your reply. Tried everything, still not working. Check configs here: "SiteURL": "",
and Nginx config is in /etc/nginx/conf.d/mattermost.conf by default. Password: mattermost


Hey, @timowevel

The NGINX configuration looks fine. I just want to understand the problem a little better here:

Specific to this statement, do you mean that even if you type in, the browser redirects the page to

Can you also provide more context to the problem? Is the actual problem referring to Mattermost or Jitsi ?

Also, how does the Jitsi configuration look like using the cat /opt/mattermost/config/config.json | grep -A2 "jitsi" command?

ahmaddanial@mattermost:~$ cat /opt/mattermost/config/config.json | grep -A2 "jitsi"
            "jitsi": {
                "jitsiappid": null,
                "jitsiappsecret": null,
                "jitsicompatibilitymode": false,
                "jitsiembedded": true,
                "jitsijwt": null,
                "jitsilinkvalidtime": 30,
                "jitsinamingscheme": "words",
                "jitsiurl": ""
            "jitsi": {
                "Enable": true


I have 2 subdomains, both pointing to the server. Its “meet.” and “mattermost.”. Both pointing with an A entry to a specific IP. When I first setup Jitsi, I access it via my subdomain “meet.”. When I setup mattermost and type in my domain with my subdomain “mattermost.” I can access mattermost fine via “mattermost.”. But when I then try to open Jitsi via my subdomain “meet.” it directly redirects me to “mattermost.”. It seems like mattermost “overtook” the webserver and redirects every request to “mattermost.”.

Output of cat CMD is exactly the same like yours. The problem is not the Jitsi Plugin, I cant even use it with my jitsiurl because you cant access it anymore as soon as I set up mattermost (the Jitsi Plugin itself just redirects to my Jitsi instance, but as soon as Mattermost runs, you cant access it anymore so the plugin also doesnt work anymore).

Hi, @timowevel

Got it. The way I understand here is that you are unable to access your Jitsi after you set up Mattermost in which the subdomain (as an example) redirects to

Mattermost works and the issue now is that you cannot access Jitsi that is hosted on your end.

How did you configure Mattermost to point to the same server? Which documentation that you referred to? At this point, I am trying to work backwards to find out which step during the deployment of Mattermost that is causing this problem.

First, I did the Jitsi setup with this guide:

After that, I installed mattermost with this guide:

I didnt do any configuration except adding in the mattermost config at SiteURL the url. So both are untouched.

Another problem is that mattermost also wont start because it says Error: listen tcp :443: bind: address already in use
when Jitsi is running.

So Jitsi is running with nginx and when I want to start mattermost it also tries to bind to port 443, but its already in use by nginx.

Hi @timowevel

That makes sense since you have both Mattermost and Jitsi installed in the same server and both are trying to use port 443 (HTTPS) at the same time.

Would you consider installing any of the app (either Jitsi / Mattermost) on a different server or consider using other ports for secure connection - ?

Will try that, thanks!

1 Like